UO expansion AOS and empty spellbook (POL 097 2008-02-26)

Bug Reports relating to the 097 core are moved to this forum once solved.

Moderator: POL Developer

Locked
User avatar
ncrsn
Grandmaster Poster
Posts: 255
Joined: Fri Feb 10, 2006 12:15 am

UO expansion AOS and empty spellbook (POL 097 2008-02-26)

Post by ncrsn » Tue Apr 08, 2008 7:12 am

At least in the latest core, if account's expansion mode is set from default to AOS (account.Set_UO_Expansion("AOS")), and nothing else is changed, all spellbooks appear empty.

Instead of correct packets 0x24 (Draw Container) & 0x3C (Items In Container), POL sends 0x25 (Add Item To Container) & 0x24 (Draw Container). Especially weird this is because if spellbook is opened using UO::SendViewContainer(), correct packets are sent and spells show up correctly.

Because spellbook's usescript is not started even if set in itemdesc.cfg, fixing this clean way requires hooking doubleclick and handling spellbook in there.

I thought this is still worth reporting.

Nando
POL Developer
Posts: 260
Joined: Wed Sep 17, 2008 6:53 pm
Contact:

Re: UO expansion AOS and empty spellbook (POL 097 2008-02-26)

Post by Nando » Tue Dec 30, 2008 9:55 pm

ncrsn, do this bug still exist? I haven't tested (MuadDib is going to do this soon =x), but checking the code I can't see a way this would happen.

I'd be glad if you could give more information. It just happens when you set the expansion via script? If you logout and reconnect, can you now see the book? If you save your shard (but still logged in), can you see the book now? This ALWAYS happens? :)

Thanks.

User avatar
ncrsn
Grandmaster Poster
Posts: 255
Joined: Fri Feb 10, 2006 12:15 am

Re: UO expansion AOS and empty spellbook (POL 097 2008-02-26)

Post by ncrsn » Wed Dec 31, 2008 2:19 am

I tend to test things couple of times before reporting, but if you wish, I'll recheck this one. After all there are new releases and it's been a while since I noticed this, so I can't say for sure no longer.

It will take at least few days, but I'll take another look at this and eventually get back to you.

MuadDib
POL Expert
Posts: 1090
Joined: Sun Feb 12, 2006 9:50 pm
Location: Cross Lanes, WV

Re: UO expansion AOS and empty spellbook (POL 097 2008-02-26)

Post by MuadDib » Sat Jan 03, 2009 12:32 pm

This is an age old CLIENT bug.

Turn AOS features on via servspecopt.cfg Feature Enable. Once that is set 0x20, your client will see the books.
POL Developer - The Penguin Scripter

MuadDib
POL Expert
Posts: 1090
Joined: Sun Feb 12, 2006 9:50 pm
Location: Cross Lanes, WV

Re: UO expansion AOS and empty spellbook (POL 097 2008-02-26)

Post by MuadDib » Sat Jan 03, 2009 12:38 pm

ncrsn wrote:if spellbook is opened using UO::SendViewContainer(), correct packets are sent and spells show up correctly.
Yes and no. Spellbooks are requiring a different style packet entirely for this. You are seeing them due to a bug in the client, as it builds these new spellbooks (AOS+) via a bitwise flag per circle. The AOS+ client is not seeing them at all because you have not enabled the 0x20 Feature (to fully activate AOS+ viewing of spellbooks).
POL Developer - The Penguin Scripter

MuadDib
POL Expert
Posts: 1090
Joined: Sun Feb 12, 2006 9:50 pm
Location: Cross Lanes, WV

Re: UO expansion AOS and empty spellbook (POL 097 2008-02-26)

Post by MuadDib » Thu Jan 29, 2009 4:27 pm

Code: Select all

01-28-2009 MuadDib:
    Changed: Rewrote ObjCache Building. Now constructs the packet for uokr/aos once when sending
             to a group (send to in range). Previous method built this packet per client requiring
             it. Should improve handling in populated areas.
    Fixed:   Client bug where AOS Expansion accounts could not see normal magery books without
             UOFeatureEnable 0x20 bit set. Although this IS a client bug, found a way to fix this
             VERY common bug server-side. As a feature of this fix, you can now have the AOS
             features that do NOT require 0x20 (tooltips etc), AND the magery books work without
             packet hooks.
This will be for the next 098 Beta (not in 097, not a critical bug update, client fix instead).
POL Developer - The Penguin Scripter

User avatar
ncrsn
Grandmaster Poster
Posts: 255
Joined: Fri Feb 10, 2006 12:15 am

Re: UO expansion AOS and empty spellbook (POL 097 2008-02-26)

Post by ncrsn » Mon Feb 16, 2009 3:55 pm

To my setup, the latest 098 beta release fixed the issue.

Thanks for doing extra work with this, especially because I as the scripter am the one to blame.

Locked