Problems while updating POL Core

Discussion about the development of POL's official distribution scripts.

Moderators: POL Developer, Distro Developer

Locked
Daviex
Neophyte Poster
Posts: 38
Joined: Sat Sep 20, 2008 3:53 am
Location: Sicily, Italy

Problems while updating POL Core

Post by Daviex » Tue Mar 22, 2016 6:40 am

Hello.

So, today I'm here to ask for some help.

I'm trying to update my server from a POL099 Core of 2009 to the recent one. I've already compiled it,
recompiled the scripts under new modules, and all was fine. Adjusted what was wrong with Config Files,
removed from POL.Cfg the ListenPort and ClientEncryption, added the UOClient.cfg, with Listener with information it needs to run,
but it won't work. I mean, it start and all, seem really fine to log in, but when I try to log on it says "Connecting".

Someone can help? If you need anything to help, just ask.

Thanks

Skinny
Journeyman Poster
Posts: 63
Joined: Wed Dec 19, 2012 10:27 pm

Re: Problems while updating POL Core

Post by Skinny » Tue Mar 22, 2016 9:02 am

Hi.

Try to disable your firewall temporarily or to add the listen ports and see if connect.

Daviex
Neophyte Poster
Posts: 38
Joined: Sat Sep 20, 2008 3:53 am
Location: Sicily, Italy

Re: Problems while updating POL Core

Post by Daviex » Sat Mar 26, 2016 7:01 am

Skinny wrote:Hi.

Try to disable your firewall temporarily or to add the listen ports and see if connect.
Hey, thanks for the answer.

Well, I don't think is that the problem. If I start my old POL server, it works without problems, I can log in and everything.

Skinny
Journeyman Poster
Posts: 63
Joined: Wed Dec 19, 2012 10:27 pm

Re: Problems while updating POL Core

Post by Skinny » Sat Mar 26, 2016 7:49 am

Do you check the '/config/servers.cfg' settings?

Code: Select all

GameServer
{
    Name    YOUR_NAMESERVER
    IP      YOUR_IP
    Port    YOUR_PORT_NUMBER
}

Compare pol.cfg versions and check for changes.

Daviex
Neophyte Poster
Posts: 38
Joined: Sat Sep 20, 2008 3:53 am
Location: Sicily, Italy

Re: Problems while updating POL Core

Post by Daviex » Sat Mar 26, 2016 9:22 am

Skinny wrote:Do you check the '/config/servers.cfg' settings?

Code: Select all

GameServer
{
    Name    YOUR_NAMESERVER
    IP      YOUR_IP
    Port    YOUR_PORT_NUMBER
}

Compare pol.cfg versions and check for changes.
Yea, it is exactly the same as before, I only changed the POL.cfg by removing the Port and Encryption from this and by placing it into the uoclient.cfg

Nando
POL Developer
Posts: 259
Joined: Wed Sep 17, 2008 6:53 pm
Contact:

Re: Problems while updating POL Core

Post by Nando » Sat Mar 26, 2016 5:10 pm

What are the last lines in the console (near "Game is active")? When did you compile your pol? What is the value of the Multithread property in POL.cfg?

:)

Locked