The new housing systems are now in the Distro (Modern Distro.

Discussion about the development of POL's official distribution scripts.

Moderators: POL Developer, Distro Developer

Post Reply
Yukiko
Distro Developer
Posts: 2767
Joined: Thu Feb 02, 2006 1:41 pm
Location: San Antonio, Texas
Contact:

The new housing systems are now in the Distro (Modern Distro.

Post by Yukiko » Sun Aug 02, 2020 12:31 pm

First, let me say to those of you who might be using the Distro on a live shard, I am sorry. I said I would give you warning before I pushed the housing system change to the Distro repo. I simply forgot.

Second, I have created documentation for the new static housing system so that staff can set up static houses. The Distro documentation can be found in /<POL root/docs/Distro Documentation. Also now in the documentation are docs for the gumps package. These were started by Austin. I have added newer functions to the docs and I will probably be doing minor updates to them. I am slowly getting better at editing HTML code. So I will probably be tweaking the other docs to fix things up and make the pages appear more consistent.

There is also a new package called houseExtras. It is in the /pkg/items directory. Currently, it only contains house teleporters but I am going to move the Bountiful Chest and the Fountain of Life pkgs into houseExtras. I created deeds for Bountiful Chest and Fountain of Life. So, using a deed for them, they can only be placed in a house. The house extras work with both multi and static housing systems.

One thing I will be doing is creating documentation for players for some of the systems. I think the housing systems and houseExtras will be first on that list. I will either create the player docs in Open Document Format (ODF) or as HTML docs. I am leaning toward ODF so that shard devs can more easily convert them to HTML for their shard's webpages.

I would appreciate any input on that.

I also changed the name of an "include" file in :gumps:include. It was called yesNoSizable.inc. It is now confirmationSizable.inc. It never presented a yes/no gump. It presented an okay/cancel gump. So "confirmation" is a better name for the include. The main function was also renamed to ConfirmationSizable(). Internally it still has functions named with "yesno" but I left those as they were. I updated all scripts that called yesNoSizable to call confirmationSizable.inc.

I think that covers the major changes (damage? :) ) I've done.

Oh yes, one last item. When you compile the latest version of the Distro you will notice there are no warnings about unused variables. You have Asylum to thank for cleaning those up. He still hasn't told me his secret for getting it done so fast :P

Post Reply