Page 1 of 1

Problem running POL 98

Posted: Wed Jun 19, 2019 8:54 am
by schaukoski
Hi there!

Im trying to run a POL 98 here, but i get this error:

Reading Configuration.
checkpoint: reading config/bannedips.cfg
checkpoint: reading servspecopt.cfg
checkpoint: low-fragmentation Heap ...disabled via ServSpecOpt
checkpoint: init default itemdesc defaults
checkpoint: loading POL map file
Loading Realm britannia.
Server Shutdown: loading POL map file
Execution aborted due to: BinaryFile::Open('realm/britannia/statidx.dat, 0x1) failed.

I have executed the UOCONVERT.exe, but did not help.


Re: Problem running POL 98

Posted: Wed Jun 19, 2019 9:02 am
by Yukiko
For POL 098 there is a starthere.bat, for Windows, or a for Linux, in the POL folder. I suggest that you use that. It has functions for copying the required files to your POL installation and It runs uoconvert with the correct parameters to do the realm generation.

Re: Problem running POL 98

Posted: Thu Jun 20, 2019 4:21 am
by schaukoski
Hello Yukiko, thanks for the reply.

When i open StarHere.bat, it shows a console gump with some commands available, but every command i try nothing happens. It seems that show some text and refreshs the console.

Any ideas?


Re: Problem running POL 98

Posted: Thu Jun 20, 2019 4:21 pm
by Yukiko
I have been busy most of the day. I will post a walk through on the use of the starthere file later today. I haven't used it in a while but if I remember correctly things need to be done in certain order. That could be the reason why it didn't work.

Re: Problem running POL 98

Posted: Thu Jun 20, 2019 11:11 pm
by Yukiko
Ok. Here is my walk-through:

When you run starthere.bat the first menu you see is:

Code: Select all

StartHere.bat by Austin
Command        Purpose
 [ a ] - RealmGen menu        (Realm building tools)
 [ b ] - Ecompiler menu       (Ecompile tools)
 [ c ] - Cleanup menu         (File removal tools)

 [ d ] - Start POL.exe        (Returns to menu on exit)
 [ e ] - Keep POL.exe running (Restarts when it exits. Use CTRL+C to stop)

 [ x ] - Quit
Choose option a. Hit the <ENTER> key. You will see this menu:

Code: Select all

RealmGen.bat by Austin
Command        Purpose
 [ a ] - Build multis.cfg
 [ b ] - Build tiles.cfg
 [ c ] - Build landtiles.cfg
 [ d ] - Build all config files

 [ e ] - Build 'Britannia' realm     (mapid=0)
 [ f ] - Build 'Britannia Alt' realm (mapid=1)
 [ g ] - Build 'Ilshenar' realm      (mapid=2)
 [ h ] - Build 'Malas' realm         (mapid=3)
 [ i ] - Build 'Tokuno' realm        (mapid=4)
 [ j ] - Build 'Ternur' realm        (mapid=5)
 [ k ] - Build all realms - Takes a very long time!

 [ o ] - Copy needed client files to pol\MUL\

 [ x ] - Back
Choose option o Hit the <ENTER> key. You will see the prompt:

Code: Select all

Full path to UO directory:
Enter the full path to your UO installation and hit the <ENTER> key.
The required files will be copied from your UO directory to the /MUL directory in your POL installation.
Once the files are copied you will be prompted to press a key. Do that and the RealmGen menu wil reappear. Choose option d to build all config files. You might see a bunch of text being output that says "Type 0xXXXX not found in uoconvert.cfg, assuming "House" type." ehere XXXX is some hexadecimal number. Unless you get a definite error, you can ignore it. Press a key when prompted to do so.

A quick note about "realms", that is POL terminology for facets. See my complaint below about Felucca and Trammel and apply that to realms as well. :)

Now you have a choice to make. If you are only going to use the main map, Felucca (called "britannia" in the menu.), you can enter the letter e and press <ENTER> and uoconvert will generate the map. If you are going to use some maps then choose a map. Let it be generated and choose the next one etc. If you are planning on using all of the maps there is an option to generate them all.

Please note that the Trammel map is called "britannia_alt" in POL terminology. Don't ask me why the proper names were not given to Felucca and Trammel. It happened when POL was closed source and those of us on the outside didn't know the devs at that time were using non-standard names.

Once the realms are generated and you are back at the RealmGen menu choose option x. You will now be back at the main menu. Choose option b. In the Ecompile menu choose option e. eCompile will now attempt to compile all of your scripts. If it encounters an error it will stop and show you the file and line number where it encountered the error. If you get an error then edit the script in an editor that shows line numbers to make it easy to find the line with the error. If you need help with scripting and errors feel free to post your questions. Please start a new topic for any errors or scripting questions.

Assuming all of your scripts compiled without error, when you get back to the Ecompile menu choose x. You are back at the main menu. You can start POL from there if you wish. Just choose option d.

That about does it for the walk through.

Before you start POL, remember to edit servers.cfg in the main config folder and enter your IP and port. Also, in uoclient.cfg you will need to setup a "Listener". The comments in uoclient.cfg give you the info for setting up a Listener. uoclient.cfg might be located in the main config folder or in /pkg/systems/accounts/config but it can be anywhere under your main POL directory.

Re: Problem running POL 98

Posted: Sat Jun 22, 2019 4:40 am
by schaukoski
Hey Yukiko,

Thank you so much for the well detailed explanation.

The problem im having here, i dont even reach the second menu when i press option 'a' and <enter>.
The scripts seems to refresh and go back to the main menu... the only option i can use its the 'x' and closes the program.

I will try to look the sourcecode of the .bat see if i found something

Re: Problem running POL 98

Posted: Sat Jun 22, 2019 5:30 am
by schaukoski
Yukiko, another info.

I was able to start the UOCONVERTER.exe, and finished the process.
But when i try to compile or run the POL i get the same error
Execution aborted due to: BinaryFile::Open('realm/britannia/statidx.dat, 0x1) failed.

Im using the UO mondays legacy files

Re: Problem running POL 98

Posted: Sat Jun 22, 2019 11:57 pm
by Yukiko
Look in the directory where you have POL installed. Do you have a folder named batchfiles? If you do not have that folder that will cause starthere.bat to behave as you described. Depending on where you acquired your 098 files, you could be missing some critical files needed to run POL.

If you are missing that folder, download the ZIP file attached to this post and extract it to your POL root folder. You should receive a warning asking you if you want to replace some files with the ones you are extracting. Go ahead and replace your files with the files in the ZIP archive. Now try using the walk through I posted. hopefully this will solve your problem.

Re: Problem running POL 98

Posted: Wed Jun 26, 2019 5:18 pm
by schaukoski
Yukiko, thank you!
It worked! Im almost done! heheh

I found out that the problem was that my UO folder has a large path or spaces in path. So i moved my uo installation to c:/uoml and worked, builded the realm, and compiled everything successfull.

Now im gettint some error when i try to run the POL.exe

Loading package in pkg/utils/timeutils/
INSTALLING: Exported Vital - RegenRate and MaxValue functions ...
Server Shutdown: initialize_client_interfaces
Execution aborted due to: Bad UO Skill ID

Founded that script with this message:
use uo;

include "include/attributes";

var npcdesccfg := ReadConfigFile("::npcdesc");

program regen()
print("INSTALLING: Exported Vital - RegenRate and MaxValue functions ...");
return 1;

exported function GetLifeRegenRateExported(mob)
if( rate != error )
rate := Cint(rate);
if( rate != error )
return rate;

return 1200;

also i fonded in file:

** This file contains most of the possibly useful functions and constants relative
** to the core 094 attributes system.
** in order to have to compile well.
** You can also want to move the SKILLID_* constants from
** to this file. in this case you should remove the include "include/client";
** statement from this file and instead add include "include/attributes"; to your
** 1) Add the new skillid to the specified CFGFILESPEC_SKILLSDEF.
** 2) Add the new attribute to your attributes.cfg.
** 3) Create a new SKILLID_ constant to fit the given skillid.
** 4) Create a new ATTRIBUTEID_ constant to fit the given attribute name.
** 5) Add a line to GetAttributeIdBySkillId( skillid ) function like:
** newSKILLID_: return newATTRIBUTEID_;
** 6) Add a line to GetSkillIdByAttributeId( attributeid ) function like:
** newATTRIBUTEID_: return newSKILLID_;
** 7) Add the new SKILLID_ to GetSkillIds() function.
** 8) Add the new ATTRIBUTEID_ to GetAttributeIds() function.
** 9) Be happy :)

Can you help me? :)

Thanks man!!

Re: Problem running POL 98

Posted: Thu Jun 27, 2019 9:56 pm
by Yukiko
It looks like you have a skill not defined correctly in the uoskills.cfg file. Which shard's scripts are you trying to use? I am also curious to know if they are 098 compatible and also why you are not using the current official POL Core version 099 1?

Anyway, until I have some idea which script set you're working with I would be just guessing.

Re: Problem running POL 98

Posted: Sun Jun 30, 2019 10:48 am
by schaukoski
Hello Yukiko,

Its a zuluhotel shard.
I have another shard in POL 99.
But i dont have the batch files for it, do you have it? I guess i will try to run that.


Re: Problem running POL 98

Posted: Sun Jun 30, 2019 5:21 pm
by Yukiko
The batch files from the 098 Core will work for the POL 099 as well. If you download the POL 100 Core you can use the Configurator. It provides a graphical user interface for setting up and configuring POL.