Problem reading elemental resist and damage members.

Get Help on scripting in POL with configurations, config setups, script trouble shooting, etc.

Moderator: POL Developer

Post Reply
Yukiko
Distro Developer
Posts: 2281
Joined: Thu Feb 02, 2006 1:41 pm
Location: San Antonio, Texas
Contact:

Problem reading elemental resist and damage members.

Post by Yukiko » Mon Nov 13, 2017 4:34 pm

I don't seem to be able to read the resist_ property from an NPC.
I set it in the npcdesc.cdf file with:

Code: Select all

EnergyResist  80
DamageFire   40
And I try to read it back and report using:

Code: Select all

	var Thing := Target(who);
	SendSysMessage(who, "Energy resistance is " + CStr(thing.resist_energy), 1, 88);
	SendSysMessage(who, "Fire damage is " + CStr(thing.damage_fire), 1, 88);
	return;
but it reports as 0 for both properties.

Am I doing it wrong?

I am using the latest Core build just in case anyone is wondering ;)
Sincerely,
Yukiko

I would tell you a UDP joke but you might not get it.

Titus 2:13

Yukiko
Distro Developer
Posts: 2281
Joined: Thu Feb 02, 2006 1:41 pm
Location: San Antonio, Texas
Contact:

Re: Problem reading elemental resist and damage members.

Post by Yukiko » Mon Nov 13, 2017 7:59 pm

Tested on the previous Core release of 2017-09-11 and they did not work on that release either.
Sincerely,
Yukiko

I would tell you a UDP joke but you might not get it.

Titus 2:13

Yukiko
Distro Developer
Posts: 2281
Joined: Thu Feb 02, 2006 1:41 pm
Location: San Antonio, Texas
Contact:

Re: Problem reading elemental resist and damage members.

Post by Yukiko » Wed Nov 15, 2017 9:06 am

This was a Core bug and will be fixed in the next build.
Sincerely,
Yukiko

I would tell you a UDP joke but you might not get it.

Titus 2:13

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests