multis.cfg

Get Help on scripting in POL with configurations, config setups, script trouble shooting, etc.

Moderator: POL Developer

Post Reply
mr bubbles
Grandmaster Poster
Posts: 120
Joined: Thu Jan 18, 2007 2:34 am

multis.cfg

Post by mr bubbles » Thu Apr 07, 2011 2:22 am

Decided to learn how to make a new multi, a boat.

What I've done is use UO Fiddler to create the multi (at it's just a rectangle, testing stage) and saved it into the multi multi.mul/multi.idx file.

I converted the new multi file into POL and opened the multi.cfg to see if it worked. I see my multi in there and can add it in game, so awesome.

Few questions though.

1. How does the cfg file know what type of multi it is? It listed it as 'House' and not 'Boat'. I also see a 'Stairs' type. Does it select the 'Boat' type if there is a tillerman graphic?

2. I see 'Static' and 'Dynamic' as 2 possibles. All the parts in my new 'boat' have been given the 'Dynamic' tag. Why is this and what difference does it make? Obviously with dynamic each part can be altered in game, but is it then really a multi? By that I mean, is it as bandwidth friendly as a multi, or is it treated like a created item and cause more lag.

3. Can the multi.cfg file be manually edited? I don't mean to add objects into it, but to change something from dynamic to static or whatnot?

Cheers for the help

mr bubbles
Grandmaster Poster
Posts: 120
Joined: Thu Jan 18, 2007 2:34 am

Re: multis.cfg

Post by mr bubbles » Thu May 19, 2011 12:43 am

Ok, totally different question. For some reason whenever I place a multi, house or boat. Only the dynamic (doors, signs) items are being shown. It's like the other pieces are there, since I run into them like an invisible wall.

At a loss as what to do now. I have recompiled the multi.cfg. Used a fresh multi.mul and used that to make a new multi.cfg incase it was my fault. But no, I just can't get any multi to show! Hell, I even reinstalled UO, tried different clients.

The scripts are working fine. All multi's DO create when I make them, they just show the doors like i said earlier. Looking at multis.txt, all the info is there. They SHOULD be visible?

Any ideas?

Edit: Derrrrp. Figured it out. I had it set up for MaxTileID=0x7FFF and wasn't using a 7+ client. sorry

Post Reply