[fixed] Assertion Failed - POL freeze

Post Reply
Skinny
Expert Poster
Posts: 76
Joined: Wed Dec 19, 2012 10:27 pm

[fixed] Assertion Failed - POL freeze

Post by Skinny » Mon Jul 21, 2014 10:24 pm

Hi.

I've had problems with freezing POL for months and i can not find a solution.
When occurs, all players are disconnected and if i try to re-connect, it stop in "Verifying account..." and i can't join the game.
The wierd situation is when the problem occurs, because it is not saving the datalog in the "pol.log" file. So, i don't know where is the problem, if it's a POL Core Bug or a Script Bug.

The last logging line sometimes is this:

Code: Select all

[06/22 00:10:59] Assertion Failed: contents_.empty(), containr.cpp, line 73
Another last logging line sometimes is this:

Code: Select all

[04/10 02:52:29] Assertion Failed: itr != zone.items.end(), uworld.cpp, line 57
Or sometimes, just no line error is logged and shown.

In the console is just appearing a loop with these data:

Code: Select all

6032 - SocketClientThread
6044 - SocketClientThread
6056 - SocketClientThread
6060 - SocketClientThread
6064 - SocketClientThread
6068 - SocketClientThread
6080 - SocketClientThread
6088 - SocketClientThread
6100 - SocketClientThread
6104 - SocketClientThread
6108 - SocketClientThread
6112 - SocketClientThread
6116 - SocketClientThread
6120 - SocketClientThread
6128 - SocketClientThread
6132 - SocketClientThread
6136 - SocketClientThread
Child threads (child_threads): 613
Registered threads (ThreadMap): 614
See the printscreen:
Image

I try to close the POL with saving the world (Ctrl+C), but it does not allow and back to the loop of thread.
I'm using the: POL099-2013-09-03 Break Everything Even Rudder (VS.NET 2012 - 64bit) compiled on Jan 20 2014 23:35:16 running.


Can anyone help?

Xeno
New User
Posts: 23
Joined: Wed May 09, 2012 9:53 am

Re: Assertion Failed - POL freeze

Post by Xeno » Tue Jul 22, 2014 2:37 am

Try to rebuild Core with last revision ( now [r826] ) from SVN and recompile all scripts.

Skinny
Expert Poster
Posts: 76
Joined: Wed Dec 19, 2012 10:27 pm

Re: Assertion Failed - POL freeze

Post by Skinny » Tue Nov 25, 2014 11:18 am

Xeno wrote:Try to rebuild Core with last revision ( now [r826] ) from SVN and recompile all scripts.
It's work. There was a problem in POL Core, fixed in last revision.
Thank you.

Post Reply