POL console stops at "LAN IP address is..." SOLVED

If your problem is with a specific version of the distro or core, look below. If you are unsure, this is your place.
Post Reply
Distro Developer
Posts: 2825
Joined: Thu Feb 02, 2006 1:41 pm
Location: San Antonio, Texas

POL console stops at "LAN IP address is..." SOLVED

Post by Yukiko » Sun Sep 11, 2022 3:26 pm

I had a rare issue today starting POL. I launched it and got this output.
POL did not continue loading. I even, temporarily, deleted the contents of servers.cfg file and tried restarting POL just to see how far it had gone in its execution and POL didn't complain about an empty servers file. I still got the same console output.
After checking all the usual files and checking my NIC settings I took these steps to try to resolve the issue:
1. Replacing Core files. That did not work.
2. After replacing Core files, I recompiled the scripts. That didn't work.
3. Rebuilding all the tiles config files. That resolved the issue.
Unfortunately, I did not do the tiles rebuild one at a time, and test between each one. So I don't know which tiles config file caused the issue.

I posted this because we have encountered this on rare occasions and we always have trouble remembering how to resolve the problem. This may not fix the issue in every situation where POL freezes at that point but it is something to try.

Post Reply