Setting up a Windows POL server. A tutorial.

Sometimes you need to share your knowledge. This is where you can do it. A place for POL and Script guides.
nFz
New User
Posts: 20
Joined: Thu Jun 25, 2020 1:39 pm
Location: Stockholm, Sweden

Re: Setting up a Windows POL server. A tutorial.

Post by nFz » Sat Jun 27, 2020 3:23 pm

Yes, D:\POL Server was the directory name.

ArkNem
New User
Posts: 4
Joined: Sat Nov 17, 2018 6:31 am

Re: Setting up a Windows POL server. A tutorial.

Post by ArkNem » Sat Feb 06, 2021 2:28 am

Using pol099.1 and Distro-2017-10-15 on OUML client version 4.0.11c

This is the error

"Error loading script pkg/systems/attributes/regen.ecl: Recompile required. Bad v
ersion number 12
Unable to read script 'pkg/systems/attributes/regen.ecl'
Error reading script pkg/systems/attributes/regen.ecl
Error reading configuration file pkg/systems/attributes/config/vitals.cfg:
Export Script pkg/systems/attributes/regen.ecl not found
Element: Vital Life, found on line 2
Server Shutdown: load_vitals_cfg: load_packed_cfgs
Initiating POL Cleanup....
Execution aborted due to: Configuration file error

C:\Users\Casa\Desktop\Pol99>pause
Premere un tasto per continuare . . ."

Can anyone help me? even a Discord support will be appreciate, i'm very naab

Titanium
New User
Posts: 1
Joined: Sun May 09, 2021 4:03 pm

Re: Setting up a Windows POL server. A tutorial.

Post by Titanium » Thu May 13, 2021 5:32 pm

Hi, I am a newbie on create a POLL server I don't have any understand on how it works. As I didnt find any ISO with a game install with client 7+, actually I only find an ISO of AOS.

I download the official classic UO client from https://uo.com/client-download/.
Let it download and upgrade til UO Version 7.0.90.16.

Never create an account or loged in the game I went strait to Pol Configurator.

I followed the guide religioslly step by step, I saw some erros on the way but I doesnt know what they mean.

At the end when I clicked on button Test Launch POL, I got an erro and I have no Idea how to solve, can someone help me?

Code: Select all

INSTALLING: Exported Vital - RegenRate and MaxValue functions ...
Itemdesc has no 'graphic' specified, and no 'objtype' is valid either.
Error reading configuration file pkg/items/runicAtlas/config/itemdesc.cfg:
        Configuration error
        Element: Container 0x9C16, found on line 1
Server Shutdown: load_itemdesc
Initiating POL Cleanup....
Execution aborted due to: Configuration file error

D:\POL>pause

Content of: pkg/items/runicAtlas/config/itemdesc.cfg

Code: Select all

Container 0x9C16
{
	Name					RunicAtlasEW
	Desc					runic atlas
	Movable					1
	Weight					1
	Gump					0x003E
	MinX					40
	MaxX					60
	MinY					20
	MaxY					80
	RequiresAttention		1
 	Script					runicAtlas/use
	MethodScript			runicAtlas/methods
	OnInsertScript  		runicAtlas/onInsert
	CanRemoveScript	        runicAtlas/canRemove
	CProp	%Charges%       d2:S7:chargesi0S11:max_chargesi5
	CProp	%RuneList%      a0:
	CProp	Name            sa runic atlas
}

Container 0x9C17
{
	Name					RunicAtlasNS
	Desc					runic atlas
	Movable					1
	Weight					1
	Gump					0x003E
	MinX					40
	MaxX					60
	MinY					20
	MaxY					80
	RequiresAttention		1
 	Script					runicAtlas/use
	MethodScript			runicAtlas/methods
	OnInsertScript  		runicAtlas/onInsert
	CanRemoveScript	        runicAtlas/canRemove
	CProp	%Charges%       d2:S7:chargesi0S11:max_chargesi5
	CProp	%RuneList%      a0:
	CProp	Name            sa runic atlas
}

Nando
POL Developer
Posts: 272
Joined: Wed Sep 17, 2008 6:53 pm
Contact:

Re: Setting up a Windows POL server. A tutorial.

Post by Nando » Fri May 14, 2021 11:57 pm

Titanium wrote:
Thu May 13, 2021 5:32 pm
...

Code: Select all

INSTALLING: Exported Vital - RegenRate and MaxValue functions ...
Itemdesc has no 'graphic' specified, and no 'objtype' is valid either.
Error reading configuration file pkg/items/runicAtlas/config/itemdesc.cfg:
        Configuration error
        Element: Container 0x9C16, found on line 1
Server Shutdown: load_itemdesc
Initiating POL Cleanup....
Execution aborted due to: Configuration file error
...
Hi. First of all, welcome!

Please check MaxObjtype and MaxTileID in pol.cfg. For client 7+, MaxTileID should be 0xFFFF and MaxObjtype should be larger than that (I believe in ClassicDistro it's 0x40000). Those settings tell POL the valid range of graphics for the client.

Also, POL Configurator should have a setting for your client's expansion name. Make sure it's correct.

If neither works, feel free to show up on Discord

Post Reply