Actions Translation for Newer Client

Bug reports and feature requests. New features can only be added to the current development version. Bug-fixes may be back-ported.

Current release: 099 / Current development: 100
Post Reply
Xeno
New User
Posts: 23
Joined: Wed May 09, 2012 9:53 am

Actions Translation for Newer Client

Post by Xeno » Mon Dec 23, 2019 5:17 pm

Hi all, I'm using a 7.0.10.3 client and POL100 last rev. It seems that all translated anims for newer clients > 7.0.9.0 are ok but some animations while on mount are not visible at all: 0x17, 0x18 actions (ride fast/slow bobs up and down)

Code: Select all

  0x0 0x17 // Walk (unarmed) / Ride - slow
  0x1 0x17 // Walk (armed) / Ride - slow
  0x2 0x18 // Run (unarmed) / Ride - fast
  0x3 0x18 // Run (armed) / Ride - fast
  0xf 0x17 // Walk (warmode) / Ride - slow
  0x10 0x18 // Directional spellcast / Ride - fast (bobs up and down)
  0x11 0x17 // Area-effect spellcast / Ride - slow (bobs up and down)
  0x17 0x17 // (Ride - slow)
  0x18 0x18 // (Ride - fast)
The character seems to be completely stuck when using PerformAction(). Unmounted animations are all ok.
What it could be?

Thanks in advance.

RusseL
Forum Regular
Posts: 373
Joined: Fri Feb 20, 2009 8:30 pm

Re: Actions Translation for Newer Client

Post by RusseL » Tue Dec 24, 2019 4:16 am

There is a config animxlate, probably you can fix it there. But i don't know exactly how, never used it.

Xeno
New User
Posts: 23
Joined: Wed May 09, 2012 9:53 am

Re: Actions Translation for Newer Client

Post by Xeno » Tue Dec 24, 2019 4:32 am

RusseL wrote:
Tue Dec 24, 2019 4:16 am
There is a config animxlate, probably you can fix it there. But i don't know exactly how, never used it.
Yes here it is:

Code: Select all

MobileType Human
{
  MountTranslation 1
  # Walk unarmed
  OldAnim0 0
  NewAnim0 7 2
  # Walk armed
  OldAnim1 1
  NewAnim1 7 2
  # Run 1
  OldAnim2 2
  NewAnim2 7 2
  # Run 2
  OldAnim3 3
  NewAnim3 7 2
  # Idle
  OldAnim4 4
  NewAnim4 5 0 1
  # Look around
  OldAnim5 5
  NewAnim5 5 0 0
  # Look down
  OldAnim6 6
  NewAnim6 5 0 1
  # Warmode 1
  OldAnim7 7
  #NewAnim7 12
  # Warmode 2
  OldAnim8 8
  #NewAnim8 12
  # Attack
  OldAnim9 9
  NewAnim9 0
  # Attack thrust
  OldAnim10 10
  NewAnim10 0 5
  # Attack bigswing
  OldAnim11 11
  NewAnim11 0 6
  # Attack 4
  OldAnim12 12
  NewAnim12 0 7
  # Attack 5
  OldAnim13 13
  NewAnim13 0 4
  # Attack 6
  OldAnim14 14
  NewAnim14 0 8
  # Ready 2
  OldAnim15 15
  NewAnim15 0 7
  # Cast spell 1
  OldAnim16 16
  NewAnim16 11 0
  # Cast spell 2
  OldAnim17 17
  NewAnim17 11 1
  # Shoot bow
  OldAnim18 18
  NewAnim18 0 1
  # Shoot crossbow
  OldAnim19 19
  NewAnim19 0 2
  # Got hit
  OldAnim20 20
  NewAnim20 4 0
  # Die backward
  OldAnim21 21
  NewAnim21 3 0 1
  # Die forward
  OldAnim22 22
  NewAnim22 3 0 0
  # Walk horse
  OldAnim23 23
  NewAnim23 7 2
  # Run horse
  OldAnim24 24
  NewAnim24 7 2
  # Idle horse
  OldAnim25 25
  NewAnim25 5 0 1
  # Attack 1h horse
  OldAnim26 26
  NewAnim26 0 6
  # Attack bow horse
  OldAnim27 27
  NewAnim27 0 1
  # Attack crossbow horse
  OldAnim28 28
  NewAnim28 0 2
  # Attack 2H horse
  OldAnim29 29
  NewAnim29 0 0 2
  # Dodge
  OldAnim30 30
  NewAnim30 2 0
  # Punsh
  OldAnim31 31
  NewAnim31 0 0
  # Bow
  OldAnim32 32
  NewAnim32 7 0
  # Salute
  OldAnim33 33
  NewAnim33 7 1
  # Eat
  OldAnim34 34
  NewAnim34 6 0
That's from the official release, should I change anything? I tried changing some subcommands and actions but it seems is not a good idea, animation while dismounted are ok, I can't change the packets :shame:

Turley
POL Developer
Posts: 669
Joined: Sun Feb 05, 2006 4:45 am

Re: Actions Translation for Newer Client

Post by Turley » Tue Dec 31, 2019 1:05 am

Cannot really remember it's a few years ago, but it could be that it's just a placeholder and not a valid animation.
Sending a run/walk animation without moving makes also not really sense and the client performs this animation automatically.

Xeno
New User
Posts: 23
Joined: Wed May 09, 2012 9:53 am

Re: Actions Translation for Newer Client

Post by Xeno » Tue Dec 31, 2019 4:16 am

On clients < 7.0.9.0 these animations are displayed like bobbing up and down on the mount, for example while casting a spell. What I was just saying is that at the moment it results that on newest clients those anims are not displayed at all.

Post Reply