Green Healthbar missing?!

Bug reports and feature requests. New features can only be added to the current development version. Bug-fixes may be back-ported.

Current release: 099 / Current development: 100
Post Reply
Austa
New User
Posts: 8
Joined: Sun Sep 24, 2017 7:10 am

Green Healthbar missing?!

Post by Austa » Thu Oct 25, 2018 8:08 pm

hello, first sorry for my fucked up English, i hope u understand my problem.
we r missing the green healthbar on the pol100 linux.
if we poison a npc or other player, the healthbar is still blue, after leaving the screen and go back to the poisoned npc/player the healtbar show the correct green color, cure works fine from green to blue. on pol99 it works correctly, is there maybe a core bug?

guialtran
Grandmaster Poster
Posts: 108
Joined: Wed Jul 30, 2008 12:42 pm

Re: Green Healthbar missing?!

Post by guialtran » Thu Oct 25, 2018 8:18 pm

Hello friend, thanks for the info, it would be important and very pertinent the compilation dates of the programs that you are using, and it would be good to also know about which clients you are using.
hugs
@CronosKing
Image ZuluHotel Forgotten Realms
www.zuluhotel.com.br

Austa
New User
Posts: 8
Joined: Sun Sep 24, 2017 7:10 am

Re: Green Healthbar missing?!

Post by Austa » Thu Oct 25, 2018 8:28 pm

we use this build app.php/page/downloads (downloaded maybe 1 hr ago) for ubuntu and the client is 7.0.7.1
POL100 Never Gonna Give You Up - Linux 64bit (Rev. 5bee779)
compiled on Oct 25 2018 00:00:13

guialtran
Grandmaster Poster
Posts: 108
Joined: Wed Jul 30, 2008 12:42 pm

Re: Green Healthbar missing?!

Post by guialtran » Fri Oct 26, 2018 9:57 am

is it possible for you to test this problem with a newer client?
@CronosKing
Image ZuluHotel Forgotten Realms
www.zuluhotel.com.br

Austa
New User
Posts: 8
Joined: Sun Sep 24, 2017 7:10 am

Re: Green Healthbar missing?!

Post by Austa » Fri Oct 26, 2018 10:28 am

i test with older an newer clients, but still no poison healthbar, only if leave screen and go back.

Austa
New User
Posts: 8
Joined: Sun Sep 24, 2017 7:10 am

Re: Green Healthbar missing?!

Post by Austa » Sat Oct 27, 2018 5:20 am

if i poison myself the bar get green instant. i test with injection command resend, after the resend command the healthbar get green from npc and player. on pol98 and pol99 it works fine, only on pol100 i have this problem.

guialtran
Grandmaster Poster
Posts: 108
Joined: Wed Jul 30, 2008 12:42 pm

Re: Green Healthbar missing?!

Post by guialtran » Sat Oct 27, 2018 4:44 pm

I tested it here, it looks all normal, I can test it in front of you if you want.

I would tell you to check if you have any hooks acting on your status packs.

program my_use( chr, txt )
if(chr.poisoned)
chr.setpoisoned(0);
else
chr.setpoisoned(1);
endif
.......

try creating a point command, and test what I sent it to you.
@CronosKing
Image ZuluHotel Forgotten Realms
www.zuluhotel.com.br

Austa
New User
Posts: 8
Joined: Sun Sep 24, 2017 7:10 am

Re: Green Healthbar missing?!

Post by Austa » Sat Oct 27, 2018 10:53 pm

i test it with command like this, but it dont work.
i test with a client 6 version of uo and there it works fine, but we use the client 7 because we set our art.mul to 0x7fff and put hundreds of new tiles in it and with client 6 uo crash if we go in area where we use the new tiles. is there maybe a hook to send a update package to clients?
edit:
i use now a dirty fix
after poison i change graphic from target to his own graphic
who.graphic := who.graphic;
its not a fine fix but it works for now

guialtran
Grandmaster Poster
Posts: 108
Joined: Wed Jul 30, 2008 12:42 pm

Re: Green Healthbar missing?!

Post by guialtran » Sun Oct 28, 2018 1:11 pm

Did you try to disable the hook to see if that was the problem?
@CronosKing
Image ZuluHotel Forgotten Realms
www.zuluhotel.com.br

Austa
New User
Posts: 8
Joined: Sun Sep 24, 2017 7:10 am

Re: Green Healthbar missing?!

Post by Austa » Sun Oct 28, 2018 9:35 pm

yep we try this, but no changes

Post Reply