Stationary & Centered effect speed

Bug reports and feature requests. New features can only be added to the current development version. Bug-fixes may be back-ported.

Current release: 099 / Current development: 100
Post Reply
User avatar
Core Essence
Neophyte Poster
Posts: 38
Joined: Tue Feb 07, 2006 10:40 am
Location: Palermo, Italy

Stationary & Centered effect speed

Post by Core Essence » Fri Jan 26, 2018 1:55 am

Core Version: Pol099-2013-09-03 Break Everything Even Rudder

I've noticed that the "speed" parameter is currently being ignored in this version of the core, is it fixed later on, or is it possible to fix via packethook or something?
As of now all of the effects I've been playing have all the same speed and setting it to 0 or 80 or 255 doesn't affect it in any way, while the "loop" paramter works just fine

Yukiko
Distro Developer
Posts: 2781
Joined: Thu Feb 02, 2006 1:41 pm
Location: San Antonio, Texas
Contact:

Re: Stationary & Centered effect speed

Post by Yukiko » Fri Jan 26, 2018 9:27 am

Your POL version is severely out of date. You should update it. Also core-changes.txt lists all bug fixes and changes made since your version of the Core was created.

User avatar
Core Essence
Neophyte Poster
Posts: 38
Joined: Tue Feb 07, 2006 10:40 am
Location: Palermo, Italy

Re: Stationary & Centered effect speed

Post by Core Essence » Fri Jan 26, 2018 10:06 am

Yes I know it's out of date, but for some reason I'm forced to use that one at the moment :) I did search on the core changes of the newest versions, but couldn't find anything about this specific bug, and was searching advice for some kind of work around for that reason :)

Yukiko
Distro Developer
Posts: 2781
Joined: Thu Feb 02, 2006 1:41 pm
Location: San Antonio, Texas
Contact:

Re: Stationary & Centered effect speed

Post by Yukiko » Fri Jan 26, 2018 11:34 am

Have you asked for help with your problems using the latest version of the Core?

Hopefully one of the Core developers will be able to help with this bug.

DebugZHI
New User
Posts: 13
Joined: Thu Nov 24, 2016 7:31 am

Re: Stationary & Centered effect speed

Post by DebugZHI » Sat Jan 27, 2018 9:41 am

Yukiko,

my work colleague would say if we have source code fix for that issue.
We have already our versions source code, can u help us with sending us code fix for that specific problem?

Thank you for support

DebugZHI

Yukiko
Distro Developer
Posts: 2781
Joined: Thu Feb 02, 2006 1:41 pm
Location: San Antonio, Texas
Contact:

Re: Stationary & Centered effect speed

Post by Yukiko » Sat Jan 27, 2018 7:31 pm

I am not a Core developer. My knowledge of C++ is very limited. Turley is probably the best person to contact about the problem. You could send him a PM and explain the problem or link to your post and he might be able to help.

DevGIB
Grandmaster Poster
Posts: 247
Joined: Mon Feb 06, 2006 6:12 am

Re: Stationary & Centered effect speed

Post by DevGIB » Sun Jan 28, 2018 5:56 am

I've done a compare of the core code from your release and the current repository. From what i can see i can't find any differences.
I'm wondering if this isn't so much a case of something broken/fixed in the core but more a case of the client has maybe changed the way the packets are received for those types of animations?

Are you able to let me know which client version you are using?

User avatar
Core Essence
Neophyte Poster
Posts: 38
Joined: Tue Feb 07, 2006 10:40 am
Location: Palermo, Italy

Re: Stationary & Centered effect speed

Post by Core Essence » Sun Jan 28, 2018 6:20 am

4.0.0c, yes I know that even the client is way too much older but as I said before currently I have no option for that :)

The speed on the MovingEffect seems to work just fine altough


I assume that on the newest core version this problem is not present at all, am I right?



Edit: just tryied with OrionUO settings on client 5.0.2.0 and it still does the same stuff, applying differents kind of speed does not change anything

Post Reply