[SOLVED] Custom wearables disappear while sitting

Here you can post about UO Tools not specific to POL, but to the UO Client. This includes map editors, custom clients, mul editors (except UOFiddler, use it's forum), and so on.

Moderator: POL Developer

Post Reply
Zik
Novice Poster
Posts: 41
Joined: Sun Feb 07, 2010 9:39 am
Location: Ukraine

[SOLVED] Custom wearables disappear while sitting

Post by Zik » Fri Aug 16, 2013 11:28 am

I was adding some custom armor and haircuts and found next problem:
I'm having the same problem, but it's a bit more complicated.
I'm trying to add some custom wearables. When I started, I didn't know about "50999" limit, so I began from empty slots >1000 at first.

Well, to be short, that's what I have:
1) 6 custom shields in anim.mul slots 1005-1011.
gumps, sitting and standing animation works perfect!
2) 6 custom braided beards, copied original MedLong beard with body.def to slots 1022-1028.
gumps, sitting and standing animation works perfect!
3) a pack of 12 new haircuts, a new belt and 6 pieces of armor. Everything was copied with body.def from similar original animations. Tried slots >1000, then i'd put it to completely empty slots in range of 200-350. But then, for the test, i've moved everything to empty slots >400.
In all variants I get only standing animation and gumps, when I sit, animation of these clothes disappears.

If it's important, in all 3 cases I define anims in mobtypes.txt as
animID EQUIPMENT 0.

So what can be the problem? Original animIDs, shields and beards are showed when you sit, but other body.def copies aren't.
BTW I use client 7.0.15

After a day of test i've found a solution! I wrote all this on runuo forum, so excuse me for such copy-paste.

Well, i've found a workaround for this problem!

1) At first you have to trace your empty animation slots. I did that a long way with MS Excel: write down all empties from anim.mul to one column, and to the other column write down all entries from body.def and bodyconv.def. In the first cell of the third column enter this formula:
=IF(ISNA(VLOOKUP(A2;B$2:B$729;1;FALSE));A2;0) . Drag the cell's corner right to the end of the 1st column.
Sort the 3d column and copy all numbers - these are free slots.

NB: some of free slots may be used by some items to show only gumps (some jewellery or plate gorget). I'd recommend to move their gumps to slots +1000, and also change anim in tiledata for this item. Example - (move plate gorget from 531 to 1531).
Remember that only 404+ slots could be used as equipment!

2) then write down all animIDs you'd like to copy. In Excell you can add near empty slots some comments and animID to copy.
These ID's can be stored in anim.mul or anim#.mul.
As you know, anims from anim#.muls are mapped with a help of bodyconv.def, so just search your animID there. Also make a search in body.def to make sure your animID isn't there. If it is, you can see the base graphic.
In first case (your animID is in anim.mul) open UOFiddler -> Animations -> Animation Edit -> Choose anim.mul -> find that slot and export animation to .vd .
Then find your empty slot and Import that anim from .vd.
In second case it's easier. Go to bodyconv.def, find your animID number in first column and copy all row. Go to the bottom, paste this row, and change the first number to the empty slot number.

3) and the last step - in mobtypes.txt - add entries of your new animations.
Someting like 531 EQUIPMENT 0, but you'd better copy flag number from original animation.

These steps helped me to solve a problem with disappearing animation of custom wearables when a char is sitting.
BTW I didn't try to map new anims to slots over 1000 with bodyconv.def, someone can test it, because i feel that can work too!

Hope this will help someone!

Yukiko
Distro Developer
Posts: 2781
Joined: Thu Feb 02, 2006 1:41 pm
Location: San Antonio, Texas
Contact:

Re: [SOLVED] Custom wearables disappear while sitting

Post by Yukiko » Fri Aug 16, 2013 9:28 pm

Zik, you win the prize for solving this! I don't know what the prize is but you win it. I had this problem with our custom wearable animations disappearing and could never find a solution. I haven't checked it on the latest clients to see if it persists since I haven't added our custom stuff to the HS classic art files yet. I will be doing that in the (hopefully near) future though.

Thanks again for this info. It will be useful.

Post Reply