I have a problem displaying maps.

This is where you can discuss UOFiddler, by Turley.

Moderator: POL Developer

Post Reply
Yukiko
Distro Developer
Posts: 2231
Joined: Thu Feb 02, 2006 1:41 pm
Location: San Antonio, Texas
Contact:

I have a problem displaying maps.

Post by Yukiko » Sun Jan 22, 2012 6:28 am

Turley,

I start UO Fiddler. I set the path to my files manually. I click "Reload files". Once the files are loaded I can click each tab and have access to the various features but when I click on the map tab UO Fiddler gives me an exception error. After the paragraph informing me there was an error this line is displayed:
Unable to read beyond the end of the stream
If I click on the "Details" button I am given the following:
See the end of this message for details on invoking
just-in-time (JIT) debugging instead of this dialog box.

************** Exception Text **************
System.IO.EndOfStreamException: Unable to read beyond the end of the stream.
at System.IO.BinaryReader.FillBuffer(Int32 numBytes)
at System.IO.BinaryReader.ReadInt32()
at Ultima.TileMatrixPatch.PatchStatics(TileMatrix matrix, String dataPath, String indexPath, String lookupPath)
at Ultima.TileMatrixPatch..ctor(TileMatrix matrix, Int32 index, String path)
at Ultima.TileMatrix..ctor(Int32 fileIndex, Int32 mapID, Int32 width, Int32 height, String path)
at Ultima.Map.get_Tiles()
at Ultima.Map.GetRenderedBlock(Int32 x, Int32 y, Boolean statics)
at Ultima.Map.GetImage(Int32 x, Int32 y, Int32 width, Int32 height, Bitmap bmp, Boolean statics)
at Ultima.Map.GetImage(Int32 x, Int32 y, Int32 width, Int32 height, Boolean statics)
at FiddlerControls.Map.OnPaint(Object sender, PaintEventArgs e)
at System.Windows.Forms.PictureBox.OnPaint(PaintEventArgs pe)
at System.Windows.Forms.Control.PaintWithErrorHandling(PaintEventArgs e, Int16 layer)
at System.Windows.Forms.Control.WmPaint(Message& m)
at System.Windows.Forms.Control.WndProc(Message& m)
at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)


************** Loaded Assemblies **************
mscorlib
Assembly Version: 4.0.0.0
Win32 Version: 4.0.30319.239 (RTMGDR.030319-2300)
CodeBase: file:///C:/Windows/Microsoft.NET/Framework64/v4.0.30319/mscorlib.dll
----------------------------------------
UoFiddler
Assembly Version: 4.6.0.0
Win32 Version: 4.6.0
CodeBase: file:///C:/Portable%20Programs/UO/UOFiddler/UoFiddler.exe
----------------------------------------
System.Drawing
Assembly Version: 4.0.0.0
Win32 Version: 4.0.30319.1 built by: RTMRel
CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Drawing/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll
----------------------------------------
System
Assembly Version: 4.0.0.0
Win32 Version: 4.0.30319.236 built by: RTMGDR
CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System/v4.0_4.0.0.0__b77a5c561934e089/System.dll
----------------------------------------
System.Windows.Forms
Assembly Version: 4.0.0.0
Win32 Version: 4.0.30319.235 built by: RTMGDR
CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Windows.Forms/v4.0_4.0.0.0__b77a5c561934e089/System.Windows.Forms.dll
----------------------------------------
Controls
Assembly Version: 4.4.0.0
Win32 Version: 4.4.0
CodeBase: file:///C:/Portable%20Programs/UO/UOFiddler/Controls.DLL
----------------------------------------
System.Xml
Assembly Version: 4.0.0.0
Win32 Version: 4.0.30319.233 built by: RTMGDR
CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Xml/v4.0_4.0.0.0__b77a5c561934e089/System.Xml.dll
----------------------------------------
Ultima
Assembly Version: 4.3.2.0
Win32 Version: 4.3.2
CodeBase: file:///C:/Portable%20Programs/UO/UOFiddler/Ultima.DLL
----------------------------------------
Accessibility
Assembly Version: 4.0.0.0
Win32 Version: 4.0.30319.1 built by: RTMRel
CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/Accessibility/v4.0_4.0.0.0__b03f5f7f11d50a3a/Accessibility.dll
----------------------------------------

************** JIT Debugging **************
To enable just-in-time (JIT) debugging, the .config file for this
application or computer (machine.config) must have the
jitDebugging value set in the system.windows.forms section.
The application must also be compiled with debugging
enabled.

For example:

<configuration>
<system.windows.forms jitDebugging="true" />
</configuration>

When JIT debugging is enabled, any unhandled exception
will be sent to the JIT debugger registered on the computer
rather than be handled by this dialog box.
I am running on Windows Vista Ultimate 64bit, an AMD Athlon 64 X2 and 4Gigs of RAM. UO Fiddler version is 4.6. I've tried various compatibility mode settings and running UOF in administrator mode but nothing helps. If you have any ideas how I can resolve this issue please let me know. This is using a pre-mondain's legacy map. It is a custom map0 but UOF used to read my maps just fine.
Sincerely,
Yukiko

I would tell you a UDP joke but you might not get it.

Titus 2:13

Turley
POL Developer
Posts: 628
Joined: Sun Feb 05, 2006 4:45 am

Re: I have a problem displaying maps.

Post by Turley » Sun Jan 22, 2012 7:04 am

Have you set the map size correctly? ( in options there is a checkbox)

Yukiko
Distro Developer
Posts: 2231
Joined: Thu Feb 02, 2006 1:41 pm
Location: San Antonio, Texas
Contact:

Re: I have a problem displaying maps.

Post by Yukiko » Sun Jan 22, 2012 2:59 pm

The checkbox for "New Map Size" is unchecked. I tried checking it and when I hit the "Apply" button I get an exception error as before. If I click "Continue" and then attempt to reload the files I get the same exception error. I'm going to redownload UOF and see if maybe something became corrupted somehow.
Sincerely,
Yukiko

I would tell you a UDP joke but you might not get it.

Titus 2:13

Yukiko
Distro Developer
Posts: 2231
Joined: Thu Feb 02, 2006 1:41 pm
Location: San Antonio, Texas
Contact:

Re: I have a problem displaying maps.

Post by Yukiko » Sun Jan 22, 2012 3:07 pm

No luck. I still get the exception error. Which version of .NET does UOF require? I have up to version 4 installed. Any help is greatly appreciated.
Sincerely,
Yukiko

I would tell you a UDP joke but you might not get it.

Titus 2:13

Turley
POL Developer
Posts: 628
Joined: Sun Feb 05, 2006 4:45 am

Re: I have a problem displaying maps.

Post by Turley » Sun Jan 22, 2012 10:15 pm

If you have the wrong .net version it usually crashes during startup. So this can't be the problem. Can you send me your map/statics files?

Turley
POL Developer
Posts: 628
Joined: Sun Feb 05, 2006 4:45 am

Re: I have a problem displaying maps.

Post by Turley » Mon Jan 23, 2012 9:57 am

Checked your Files:
The problem are the static diff files your stadifi0.mul doesnt match your stadifl0.mul. I added a better errorhandling in the svn.
Both files have a len of 112, but stadifl only holds one int and stadifi holds 3ints per patched block.
If you dont want to compile it yourself simply remove the diffs from datapath.
Or if you want to correct your diffs (they only have 0 inside):
Enlarge your stadifi to a size of 336, or shrink your stadifl to a size of 36.

Yukiko
Distro Developer
Posts: 2231
Joined: Thu Feb 02, 2006 1:41 pm
Location: San Antonio, Texas
Contact:

Re: I have a problem displaying maps.

Post by Yukiko » Mon Jan 23, 2012 12:28 pm

Thank you Turley. I owe you a beer. Now all I have to do is figure out how to email it to you.
Sincerely,
Yukiko

I would tell you a UDP joke but you might not get it.

Titus 2:13

Yukiko
Distro Developer
Posts: 2231
Joined: Thu Feb 02, 2006 1:41 pm
Location: San Antonio, Texas
Contact:

Re: I have a problem displaying maps.

Post by Yukiko » Mon Jan 23, 2012 12:59 pm

I wasn't able to get the compiled UOF to work so I reduced the file size of stadifl0 and it works!

Is there some setting I need to make to Visual Studio 2010 in order to compile UOF? VS is installed with it's default settings. After a compile there are four files in the \tools\UoFiddler\UoFiddler\bin\Debug directory that match any in the pre-compiled zip file you have for download: Animationlist.xml, Controls.dll, Ultima.dll and UoFiddler.exe and ofcourse the plugins folder.

When I run UOF it asks toload a profile I load the default one and then I get a box with an OK button. I click that and it closes then nothing happens.

I assume I'm doing something wrong so if you have any tips I'd appreciate it.
It's not too big of a problem since you fixed my issue but I'd like to be able to know how to compile UOF.
Thanks again Turley.
Sincerely,
Yukiko

I would tell you a UDP joke but you might not get it.

Titus 2:13

Turley
POL Developer
Posts: 628
Joined: Sun Feb 05, 2006 4:45 am

Re: I have a problem displaying maps.

Post by Turley » Sat Jan 28, 2012 1:20 am

Mhhh weird. Do you have after startup a UOFiddler folder inside your AppData? Something like C:\Users\BLAH\AppData\Roaming\UoFiddler and are there all xml files? Especially the options_default.xml

Yukiko
Distro Developer
Posts: 2231
Joined: Thu Feb 02, 2006 1:41 pm
Location: San Antonio, Texas
Contact:

Re: I have a problem displaying maps.

Post by Yukiko » Sat Jan 28, 2012 6:25 pm

Yes. It's in \Appdata\Roaming but the UoFiddler directory is there with both an options.xml and options_default.xml

Another odd thing is I don't have the two directories named "x86" and "x64" in the \bin\Debug directory after I compile UO Fiddler. Maybe I'm looking in the wrong place for the compiled executable. I thought it should be in \POL SVN\tools\UoFiddler\UoFiddler\bin\Debug. The executable is in that folder as well as some other files that aren't in the pre-compiled archive you provide. They have extensions like pdb, application and manifest. I'm pretty ignorant when it comes to using Visual Studio but when I compile the POL Core there's no odd files in the "build" directory, just the same files you'd find in the archive on the website. I hate feeling like a newbie. Thanks for your help Turley.
Sincerely,
Yukiko

I would tell you a UDP joke but you might not get it.

Titus 2:13

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest