Page 1 of 1

client 4.0.11x

Posted: Thu May 16, 2013 8:30 am
by chad
hi...i have been peppering the poor guys in pol's irc channel with this one, hopefully someone can figure this one out.....was wanting to upgrade the client to use the first ml client....i read that pol 95 could handle it, but the problem is theres a packet that is blocking the connection......it connects, lets me choose the server, then hangs before character selection.....it works fine when using razor to connect, but thats the only way.....anyone have any ideas on a way to get it to connect without using razor? ive tried filtering it through 3 or 4 different decryption programs and no luck......thanks in advance!
chad

Re: client 4.0.11x

Posted: Thu May 16, 2013 1:15 pm
by Yukiko
I don't think your problem is with the encryption. If that was the case you wouldn't be able to connect initially as far as I understand it.

Do you get any kind of error report on the POL console when the client hangs?

There's a replacement program for Razor being developed called AssistUO. You might try using that if you don't like Razor.

Re: client 4.0.11x

Posted: Fri May 17, 2013 3:24 am
by chad
hey thanks for the reply yukiko..

the server doesnt show an error and it does show the 2 connections(1st connection, then disconnect, then reconnect).......ive tried changing the skill numbers and a few other small things(since tomi or one of the other really smart people told me that it had a different number there and that might be affecting it), but still have the same problems with it

Re: client 4.0.11x

Posted: Fri May 17, 2013 4:19 am
by Yukiko
Sorry I can't be of more help.

Have you considered just converting your files to work with POL Core 0.98?

I realize it's a pain but once it's done you will be able to use the later clients.

Re: client 4.0.11x

Posted: Fri May 17, 2013 5:18 am
by chad
ya i was about 95%(or a little higher) done with the upgrade to 99........but this would be a great way to gradually transition to 99....but thanks for trying to help yukiko.....this is one thats baffled everyone...was hoping cwo would come across this one and respond to it

Re: client 4.0.11x

Posted: Sat May 18, 2013 12:50 am
by Yukiko
Have you PMed him? Maybe he's not dropped by the forums lately. A PM should generate an email to him and he might respond faster. He's pretty helpful if he knows the answers.

Re: client 4.0.11x

Posted: Sat May 18, 2013 7:30 am
by chad
ive pmed him a few times in pol channel on irc but no luck.....might give it a shot here too, just didnt want to bug him too much

Re: client 4.0.11x

Posted: Sat May 18, 2013 11:52 pm
by CWO
I haven't been around on the client scene in a long time so I'm a bit out of practice...

a few things I would point to right away

UOClient.cfg

Code: Select all

EnableFlowControlPackets=0
and how far is your UO install patched? If its not patched as far as the client or too far beyond the client version, it could also cause conflicts.

what client version did you use before that works on your server?

Re: client 4.0.11x

Posted: Sun May 19, 2013 4:00 am
by chad
hey thanks for the reply cwo......

ok the enableflowcontrolpackets was already set to 0.....
the client wasnt patched at all...since osi took out the patching ability wasnt able to do anything with it.....its straight out of the factory box as far as that goes....
and out server uses the old 2.0 client right now

thanks again for replying

ps i dont blame you for not rooting for either of those teams ;)

Re: client 4.0.11x

Posted: Sun May 19, 2013 11:56 am
by CWO
Do any of the clients on my site work? I do have manual patches available up to a certain point which should at least make those clients work.

www.cwo333.com/clients
www.cwo333.com/patch

Obviously don't use the login.cfg that comes with them. I only put that in there to stop people from hotlinking. (my clients became the official clients for a few shards and they started linking straight to the files on my site without any mention or credit)

Re: client 4.0.11x

Posted: Sun May 19, 2013 12:16 pm
by CWO
Found it. I'm not sure why (probably packet changes), you need Razor to log in with anything beyond 4.0.4 with POL 095.

http://forums.polserver.com/viewtopic.php?f=3&t=70

Re: client 4.0.11x

Posted: Sun May 19, 2013 12:45 pm
by chad
ahh ok.....thanks for clearing that up for me cwo....ill try and track down a 4.0 client and see if it will work with the ml installation stuff

Re: client 4.0.11x

Posted: Sun May 19, 2013 1:07 pm
by CWO
I actually think that's why I stopped at 4.0.3c with the CPU fixed clients. Although I think in 4.0.5 they implemented a better CPU fix.