Compiling latest Core from Git - Getting "boost" errors. [solved]

Here you can post threads specific to the current release of the core (099)

Moderator: POL Developer

Post Reply
Yukiko
Distro Developer
Posts: 2429
Joined: Thu Feb 02, 2006 1:41 pm
Location: San Antonio, Texas
Contact:

Compiling latest Core from Git - Getting "boost" errors. [solved]

Post by Yukiko » Thu Apr 27, 2017 11:44 am

Using VB 2015 Community Edition on Windows 10 I get the following errors when I try to build the solution:

Code: Select all

Severity	Code	Description	Project	File	Line	Suppression State
Error	C1083	Cannot open include file: 'boost/algorithm/string/case_conv.hpp': No such file or directory	plib	d:\downloads\polserver-master\pol-core\clib\StdAfx.h	44	
Error	C1083	Cannot open include file: 'boost/algorithm/string/case_conv.hpp': No such file or directory	bscript	d:\downloads\polserver-master\pol-core\clib\StdAfx.h	44	
Error	C1083	Cannot open include file: 'boost/algorithm/string/case_conv.hpp': No such file or directory	clib	d:\downloads\polserver-master\pol-core\clib\StdAfx.h	44	
Error	C1083	Cannot open include file: 'boost/variant.hpp': No such file or directory	pol	d:\downloads\polserver-master\pol-core\pol\StdAfx.h	26	
Error	C1083	Cannot open include file: 'boost/algorithm/string/case_conv.hpp': No such file or directory	runecl	d:\downloads\polserver-master\pol-core\clib\StdAfx.h	44	
Error	C1083	Cannot open include file: 'boost/algorithm/string/case_conv.hpp': No such file or directory	ecompile	d:\downloads\polserver-master\pol-core\clib\StdAfx.h	44	
Error	C1083	Cannot open include file: 'boost/algorithm/string/case_conv.hpp': No such file or directory	uotool	d:\downloads\polserver-master\pol-core\clib\StdAfx.h	44	
Error	C1083	Cannot open include file: 'boost/algorithm/string/case_conv.hpp': No such file or directory	poltool	d:\downloads\polserver-master\pol-core\clib\StdAfx.h	44	
Error	C1083	Cannot open include file: 'boost/algorithm/string/case_conv.hpp': No such file or directory	uoconvert	d:\downloads\polserver-master\pol-core\clib\StdAfx.h	44	
I tried running the various "buildboost" batch files but they report various files not recognised as internal commands. I've built the Core before and never received these errors so I assume something has changed in the build procedure.

Please help.
Last edited by Yukiko on Thu Apr 27, 2017 10:08 pm, edited 1 time in total.
Sincerely,
Yukiko

I would tell you a UDP joke but you might not get it.

Titus 2:13

Yukiko
Distro Developer
Posts: 2429
Joined: Thu Feb 02, 2006 1:41 pm
Location: San Antonio, Texas
Contact:

Re: Compiling latest Core from Git - Getting "boost" errors.

Post by Yukiko » Thu Apr 27, 2017 10:07 pm

After much fiddling around I solved my problem. I downloaded the source for boost from here. ran the "bootstrap.bat" file. Then followed the message from the bat file and ran b2.exe.

You should run the batch and b2.exe files from a command prompt because you need to read the last messages and the console window will close before you can see the messages if you just double-click the files from Windows.

I cheated because the version of boost I downloaded was version 1.64 but the Core solution is looking for 1.63 so I just zipped down the boost_1_63_0 folder, deleted the folder and renamed the version 1.64 folder to boost_1_63_0.

Compilation went fine. I get alot of warnings but VS 2015 reports no errors and a successful compile.
Sincerely,
Yukiko

I would tell you a UDP joke but you might not get it.

Titus 2:13

Yukiko
Distro Developer
Posts: 2429
Joined: Thu Feb 02, 2006 1:41 pm
Location: San Antonio, Texas
Contact:

Re: Compiling latest Core from Git - Getting "boost" errors. [solved]

Post by Yukiko » Thu Apr 27, 2017 10:17 pm

One more item: the reason I was getting boost errors was because there were no boost source files in the original boost_1_63 folder. It is possible the the buildDistWin.bat file downloads those but I was compiling in the VS 2015 IDE because I wanted to modify uoconvert a tiny bit, so others who use buildDistWin.bat to build the Core may not have the same problem because it does try to build the boost library before doing anything else. I had forgotten that buildDistWin does that as well as compile the Core.
Sincerely,
Yukiko

I would tell you a UDP joke but you might not get it.

Titus 2:13

Nando
POL Developer
Posts: 260
Joined: Wed Sep 17, 2008 6:53 pm
Contact:

Re: Compiling latest Core from Git - Getting "boost" errors. [solved]

Post by Nando » Thu Apr 27, 2017 10:37 pm

Interesting. You shouldn't need to run any bootstrap and b2. The core just needs the include files from boost, no need to compile anything.

The only thing that changed is that I upgraded boost, so you need to unpack the new package. Did you run "prepareBoost.bat" again? That should unpack the files for you in the proper folder.

There shouldn't be a problem to use a newer version of boost, but in theory it could make some bugs harder to track.

Yukiko
Distro Developer
Posts: 2429
Joined: Thu Feb 02, 2006 1:41 pm
Location: San Antonio, Texas
Contact:

Re: Compiling latest Core from Git - Getting "boost" errors. [solved]

Post by Yukiko » Thu Apr 27, 2017 11:27 pm

Didn't see that batch file :(

It was last year in October the last time I compiled source so what with "minor" medical issues I probably forgot about doing that.

By the way today's Windows builds are uploaded and I'm about to post links in this forum.

I never could get a working Linux build environment. Something about my system neither VmWare nor Virtual Box likes. Vagrant just wouldn't create the VM.
Sincerely,
Yukiko

I would tell you a UDP joke but you might not get it.

Titus 2:13

Yukiko
Distro Developer
Posts: 2429
Joined: Thu Feb 02, 2006 1:41 pm
Location: San Antonio, Texas
Contact:

Re: Compiling latest Core from Git - Getting "boost" errors. [solved]

Post by Yukiko » Thu Apr 27, 2017 11:46 pm

Ok. I just looked and I did try the buildboost.bat files but I remember getting somekind of errors. That's when I finally made my initial post but no worries. I was able to get it done.

I didn't try all of them though.There are 3 different ones for x64 and x86.
Sincerely,
Yukiko

I would tell you a UDP joke but you might not get it.

Titus 2:13

Nando
POL Developer
Posts: 260
Joined: Wed Sep 17, 2008 6:53 pm
Contact:

Re: Compiling latest Core from Git - Getting "boost" errors. [solved]

Post by Nando » Thu Apr 27, 2017 11:49 pm

No worries, I should have posted something here when I upgraded boost ;)

By the way: I mean the file "lib\prepare_boost.bat", not any of the buildboost.

About Vagrant: have you tried adding virtualbox to your antivirus' whitelist? For me this solved the strange errors.

Yukiko
Distro Developer
Posts: 2429
Joined: Thu Feb 02, 2006 1:41 pm
Location: San Antonio, Texas
Contact:

Re: Compiling latest Core from Git - Getting "boost" errors. [solved]

Post by Yukiko » Fri Apr 28, 2017 12:19 am

No. Haven't done that yet. I'm using Windows Defender as my AV. A lot of the other ones are installing root certs so they can scan inside TLS connections for malware and that introduces unknown possible vulnerabilities. Some AV companies have had vulnerability issues with their certs.
Sincerely,
Yukiko

I would tell you a UDP joke but you might not get it.

Titus 2:13

Post Reply