Page 1 of 1

strange builds error

Posted: Tue Jan 24, 2017 1:56 am
by az_rieil

Code: Select all

C2582: function "operator =" unaviable in "Pol::Bscript::TmplExecutorModule<Pol::Module::BasicIoExecutorModule>::FunctionDef" (module\basiciomod.cpp)	C:\Program Files (x86)\Microsoft Visual Studio 12.0\VC\include\utility
and 42 same errors in this and other files.

Latest version of https://github.com/polserver/polserver
Build on VS2013
Errors on any builds (Release/Debug/32/64)
Windows 7 x64
.NET 4.6.1
MVC lib 2005-2015

any ideas? thx for help

Re: strange builds error

Posted: Tue Jan 24, 2017 5:27 am
by boberski
Yeap, something is definitely wrong with windows build, sam from VS2013 and VS2015.

Re: strange builds error

Posted: Tue Jan 24, 2017 5:53 am
by Nando
Could you please post a longer log of the errors? It would be nice to see what is going on, as I can't try to compile it right now.

Re: strange builds error

Posted: Tue Jan 24, 2017 7:35 am
by boberski
Ok...

VS2015 Output: http://pastebin.com/w2fygCB8
VS2015 Error: I had only warnings in console, strange....

VS2013 Output: http://pastebin.com/8tfWUQAy
VS2013 Error: http://pastebin.com/HFwyYMUF

Re: strange builds error

Posted: Tue Jan 24, 2017 7:59 am
by Nando
For VS2015, could you clean the build files and try again? The error seems to be from the win2kcompat file, which shouldn't be a problem...

For VS2013, I think some feature from C++11 is missing. I'll check when I get home.

Re: strange builds error

Posted: Tue Jan 24, 2017 8:40 am
by boberski

Re: strange builds error

Posted: Tue Jan 24, 2017 9:19 am
by Turley
Please switch from debug build to release. Could be that debug is broken, but I highly doubt that you build debug on purpose ;)

Re: strange builds error

Posted: Tue Jan 24, 2017 11:45 am
by boberski
buildDistWin.bat also fail to buil :(

Re: strange builds error

Posted: Tue Jan 24, 2017 11:58 am
by Turley
Cause it isn't yet updated to vs2015. The batch compiles with 2013.
Have you checked out release build in 2015, after cleaning?

Re: strange builds error

Posted: Tue Jan 24, 2017 11:59 am
by boberski
Yeap, and everything is the same. Same linking errors as in debug mode.

Re: strange builds error

Posted: Tue Jan 24, 2017 12:52 pm
by az_rieil
Turley wrote:
Tue Jan 24, 2017 9:19 am
Please switch from debug build to release. Could be that debug is broken, but I highly doubt that you build debug on purpose ;)
as i said, i tried all configurations on 2013 - Release/Debug/32/64, same errors always

Re: strange builds error

Posted: Tue Jan 24, 2017 1:00 pm
by Nando
Please check the current commit. Should be fixed now, let me know if it persists.

Re: strange builds error

Posted: Tue Jan 24, 2017 1:33 pm
by az_rieil
working for now, thanks

Re: strange builds error

Posted: Tue Jan 24, 2017 4:35 pm
by boberski
Ok, VS2013 project works well 2015 same as it was, buildDistWin.bat gives me:

Code: Select all

Extracting boost libraries
Nothing to do. Files already extracted.
Building Win32-release from "pol-2015.sln"...
Building x64-release from "pol-2015.sln"...
Something went wrong. Check the logs in the 'dist' folder.
Press any key to continue . . .
and no logs in dist folder :)

Re: strange builds error

Posted: Wed Jan 25, 2017 12:34 am
by Nando
Aderal, can you remove all the old object files and try again? I think in Visual Studio you can go to Build -> Clean

Re: strange builds error

Posted: Wed Jan 25, 2017 2:23 am
by boberski
I done that before every single build.

Re: strange builds error

Posted: Wed Jan 25, 2017 3:10 am
by Nando
Can you do a git status and see what is modified in your local repository? Make sure everything is back to the original state from github.

Re: strange builds error

Posted: Wed Jan 25, 2017 5:04 am
by boberski
Yeap, I have newest commit without any modyfications.