No doors/signs on housing package.

Here you can post threads requesting help on the official POL Ultima Online Emulator Core 096.
Note: Core 096 is no longer officially supported.

Moderator: POL Developer

Post Reply
User avatar
andenixa
Grandmaster Poster
Posts: 105
Joined: Tue Nov 09, 2010 1:33 am

No doors/signs on housing package.

Post by andenixa » Tue Dec 28, 2010 3:56 am

Hello everyone,

We recently moved to 96.7 core and the weird bug occurs - whenever one places a house it is created with no doors or signs.

I read the old post from Austin which says:
The transparent picture you see on your cursor is entirely client-side.
When you place the multi, some stuff becomes a dynamic server-side item.

You need to have entries for the signs in an itemdesc.cfg
See the distro housing package for reference.
But I beleive we do have all the doors and signs in itemdesc, still they don't appear. Do they need any special flagging?

Since 96 distro is non-existent I can't look for its housing package neither.

Thank you very much in advance.

xeon
Forum Regular
Posts: 333
Joined: Fri Oct 31, 2008 3:18 am
Location: Italy
Contact:

Re: No doors/signs on housing package.

Post by xeon » Tue Dec 28, 2010 6:42 am

Hi andenixa, the house signs are two or three items, if I remember correctly, which are defined in the multi package.

If you think that they are defined, post them, so at least we can see if there's some problems with them.
Scripter Xeon | Zulu Hotel Italia 7th Age | www.zhi.it
Image

User avatar
andenixa
Grandmaster Poster
Posts: 105
Joined: Tue Nov 09, 2010 1:33 am

Re: No doors/signs on housing package.

Post by andenixa » Tue Dec 28, 2010 7:12 am

For example, the Tower Multi has wooden sign defined in housing package:

Code: Select all

Item 0x0bd0
{
    Name                    woodensign
    Script                  sign
    ControlScript           signcontrol
    movable                 0
    Doubleclickrange        6
}
This item appears when placing a Tower at 95 core, but the signpost is empty when placing the same house at 96 core based server.

User avatar
andenixa
Grandmaster Poster
Posts: 105
Joined: Tue Nov 09, 2010 1:33 am

Re: No doors/signs on housing package.

Post by andenixa » Wed Dec 29, 2010 9:06 pm

Apparently people don't even look at the posts which already have replies.

xeon
Forum Regular
Posts: 333
Joined: Fri Oct 31, 2008 3:18 am
Location: Italy
Contact:

Re: No doors/signs on housing package.

Post by xeon » Thu Dec 30, 2010 3:30 am

So, if you put an house in game with POL095, it works fine.
You shutdown, and start POL096, and doesn't work anymore?
Scripter Xeon | Zulu Hotel Italia 7th Age | www.zhi.it
Image

User avatar
andenixa
Grandmaster Poster
Posts: 105
Joined: Tue Nov 09, 2010 1:33 am

Re: No doors/signs on housing package.

Post by andenixa » Thu Dec 30, 2010 7:58 am

The house build at 95 core continues to work, but if I put the same house with 96 core running, doors and signs will be missing (on the new house).

User avatar
CWO
POL Expert
Posts: 1142
Joined: Sat Feb 04, 2006 5:49 pm
Location: Chicago, IL USA
Contact:

Re: No doors/signs on housing package.

Post by CWO » Thu Dec 30, 2010 12:30 pm

have you done UOConvert multis? And has the multis.cfg that UOConvert made been copied to the config path?

User avatar
andenixa
Grandmaster Poster
Posts: 105
Joined: Tue Nov 09, 2010 1:33 am

Re: No doors/signs on housing package.

Post by andenixa » Thu Dec 30, 2010 8:08 pm

That might be the issue. Thanks a lot CWO.

Post Reply