Tiledata.mul problem with unlit heating stands.

Open discussion forum. For topics that do not fit anywhere else.

Moderator: POL Developer

Post Reply
Yukiko
Distro Developer
Posts: 2411
Joined: Thu Feb 02, 2006 1:41 pm
Location: San Antonio, Texas
Contact:

Tiledata.mul problem with unlit heating stands.

Post by Yukiko » Tue Mar 06, 2018 11:41 pm

The tiledata.mul has the two unlit heating stands flagged as light sources. When you place them they create a light pattern in the area, a strange light pattern. The only way I know to fix this is to edit tiledata.mul in UO Fiddler and uncheck the light source flag in the TileData tab.

Here is an exampl of the light pattern and the Art Tile numbers for the unlit heating stands:
Image
Sincerely,
Yukiko

I would tell you a UDP joke but you might not get it.

Titus 2:13

Turley
POL Developer
Posts: 644
Joined: Sun Feb 05, 2006 4:45 am

Re: Tiledata.mul problem with unlit heating stands.

Post by Turley » Fri Mar 09, 2018 9:03 am

Instead of disabling the light you can also change the light pattern. Should be the quality entry. (Via the light tab in fiddler you can check which pattern is the best by selecting the item)

Yukiko
Distro Developer
Posts: 2411
Joined: Thu Feb 02, 2006 1:41 pm
Location: San Antonio, Texas
Contact:

Re: Tiledata.mul problem with unlit heating stands.

Post by Yukiko » Fri Mar 09, 2018 10:29 am

Yes but they are not supposed to emit any light pattern because they are not lit. Unfortunately there is no Facing setting for no light. Facing is the setting in itemdesc.cfg used to set the light pattern for light sources. So the only way I know this can be fixed is to edit tiledata.mul. If you or anyone else knows of another method please let me know.
Sincerely,
Yukiko

I would tell you a UDP joke but you might not get it.

Titus 2:13

Harley
Forum Regular
Posts: 308
Joined: Sat Mar 18, 2006 1:41 am
Location: Germany

Re: Tiledata.mul problem with unlit heating stands.

Post by Harley » Sat Mar 10, 2018 2:43 pm

I had the similar problem but didn't solve it..

Yukiko
Distro Developer
Posts: 2411
Joined: Thu Feb 02, 2006 1:41 pm
Location: San Antonio, Texas
Contact:

Re: Tiledata.mul problem with unlit heating stands.

Post by Yukiko » Sat Mar 10, 2018 4:23 pm

Yep. The problem can be solved by editing tiledata.mul in Fiddler but then you have to keep updating it as the client evolves unless you lock your players into one particular version.
Sincerely,
Yukiko

I would tell you a UDP joke but you might not get it.

Titus 2:13

DevGIB
Grandmaster Poster
Posts: 182
Joined: Mon Feb 06, 2006 6:12 am

Re: Tiledata.mul problem with unlit heating stands.

Post by DevGIB » Wed Mar 14, 2018 8:13 pm

So this is a client side error?

I'm guessing maybe OSI doesn't use this item anymore? Seems crazy to have it lit when clearly it should not be.

Post Reply